Lupa Password User Manager Mikrotik? Begini Cara Mengatasinya

Lupa nama pengguna dan kata laluan pengguna anda Mikrotik boleh membawa masalah untuk anda  menguruskan Hotspot Mikrotik Pengurus. Hal ini demikian  kerana jika anda terlupa kata laluan pengguna anda Mikrotik, anda tidak boleh menukar pangkalan data pengguna. Mikrotik Pengguna Pengurus akan memberi mesej ralat mikrotik pengurus respons pengguna “Nama pengguna tidak sah atau kata” jika anda pengguna salah atau lupa dan lulus userman beliau seperti yang ditunjukkan di bawah:

User manager Mikrotik invalid user name or password
Hal yang perlu di ingatkan bahawa username dan password user manager Mikrotik tidak selalu sama dengan user dan password untuk login ke Mikrotik nya, dan seringnya malah berbeza. Jadi pertanyaannya bagaimana cara reset password user manager Mikrotik? Sebenarnya tidak perlu di reset password user manager nya, kita tinggal lihat saja user dan pass nya melalui Terminal Winbox Mikrotik. Namun harus dipastikan dulu Anda boleh login ke Mikrotik yang diinstall user manager.

Cara Mudah Mengatasi Lupa User name dan Password User Manager Mikrotik
1. Login ke Mikrotik menggunakan Winbox Mikrotik. Jika belum punya silakan Download Winbox Mikrotik

2. Buka Terminal, masukkan arahan berikut :
tool user-manager customer print

3. Hasilnya akan muncul tampilan seperti gambar di atas. Login = username user manager, password = password user manager.

4. Untuk melakukan reset password user manager Mikrotik (edit password) boleh menggunakan perintah berikut :
tool user-manager customer edit namauser password

Silakan ganti nama user yang di warnai merah dengan username Anda. Contohnya seperti gambar di atas.

5. Tampilan terminal akan berubah menjadi sebagai berikut :


Silakan ganti password nya, jika sudah save dengan menekan tombol ctrl + o.

6. Sekarang password user manager nya sudah di reset / edit sesuai keinginan Anda. Silakan dicoba untuk login ke User manager Mikrotik.

Jadi jika Anda tidak boleh login user manager mikrotik, anda boleh cuba cara melihat username dan password atau cara ganti password user manager Mikrotik seperti yang saya tulis di atas.
Okay, selamat mencuba 🙂

 

Sumber:Kumpulan Tutorial Mikrotik Indonesia

Cara Mengatasi “No More Sessions are Allowed for User Hotspot Mikrotik”

Pesan Error Login Hotspot Mikrotik ada banyak. Pada artikel sebelum nya telah kita ulas tentang Penjelasan Pesan Error pada Halaman Login Hotspot Mikrotik. Kali ini akan kita bahas salah satu dari Pesan Error pada saat login Hotspot Mikrotik, yaitu No More Sessions are Allowed for User $(username).

Kenapa sih pesan error no more sessions are allowed for user $(username) mesti dibahas khusus?
Karena pesan error ini cukup sering muncul pada saat user hotspot login, terutama jika menggunakan username dan password yang sama untuk banyak orang.

Kenapa no more sessions are allowed for user $(username) bisa muncul?
Dari hasil terjemahan ke bahasa Indonesia sudah bisa kita ketahui bahwa : sudah tidak ada lagi sesi yang diperbolehkan untuk username tersebut. Jadi disini username yang hendak dipakai oleh user sudah tidak punya sesi lagi yang diperbolehkan oleh Server Hotspot untuk digunakan user login. Hal ini disebabkan oleh konfigurasi hotspot mikrotik pada shared user yang terbatas, sementara user yang mau login lebih dari shared user yang ditentukan oleh setingan hotspot mikrotik.
Bagaimana cara mengatasi no more sessions are allowed for user $(username)?
Pada dasarnya manajemen user hotspot pada mikrotik ada dua, yaitu user manajemen hotspot default yang bisa kita akses pada menu IP –> Hotspot –> Tab Users dan Tab User Profiles. Silakan Baca Cara Membuat Hotspot di Mikrotik : Seting dasar Hotspot Mikrotik.

Selain itu juga bisa menggunakan User Manager pada RADIUS Server. Silakan Baca disini : Cara Install dan Seting User Manager Mikrotik.

Nah, kedua fitur manajemen user tersebut punya kendala no more sessions are allowed for user $(username) serupa, namun cara mengatasinya berbeda.
Cara Mengatasi Pesan Error no more sessions are allowed for user $(username) pada User Management Hotspot Mikrotik
1. Jika anda mendapati pesan error ini sebelum bisa login ke hotspot, silakan konek ke WiFi Hotspot tanpa login. Kemudian buka Winbox dan login via Mac Address.

Mengatasi Pesan error no more sessions are allowed

2. Perlu diperhatiakan, jika Anda belum login Hotspot kemudian mau konfig Mikrotik menggunakan Winbox via IP Address tidak akan bisa. Karena ada rule firewall dinamis yang memblokir akses tersebut. Jadi silakan login via MAC Address Mikrotik.

3. Setelah login, silakan masuk ke manu IP –> Hotspot –> User Profiles –> Pilih User Profile yang digunakan.

Cara Mengatasi “No More Sessions are Allowed for User Hotspot Mikrotik”
4. Perhatikan pada opsi Shared Users Mikrotik. Pastikan jumlah shared users nya lebih banyak dari jumlah user yang diperblehkan login. Karena jika jumlah nya terbatas, user lain akan mendapati pesan error no more session dan tidak bisa login.
Cara Mengatasi Pesan Error no more sessions are allowed for user $(username) pada User Manager RADIUS Server
Berbeda dengan cara sebelumnya, untuk mengatasi no more sessions are allowed for user $(username) pada User Manager RADIUS Server tidak bisa hanya dilakukan dengan menambah Shared User pada Setingan User Manager saja. Namun tetap opsi Shared Users harus diisi sesuai penggunaan.

Mengatasi No more sessions are allowed User Manager

Pada gambar di atas, Shared User untuk user profile tamu saya set menjadi unimited. Jadi berapapun tamu yang mau akses HARUSNYA bisa terlayani dengan baik tanpa ada masalah login (Kecuali alokasi IP Address habis). Namun nyatanya tidak demikian.

Walaupun Shared Users pada User Manager di set Unlimited, Active session (sesi) user tamu yang login tetap tersimpan cukup lama dan dianggap aktif terus. Padahal user tersebut sudah tidak konek hotspot (tidak aktif). Hal ini akan mengakibatkan user tersebut dianggap masih aktif dan ketika user tersebut disconnect dan mau konek lagi atau ada user baru yang mau login jadi tidak bisa, dan muncul pesan error no more sessions are allowed for user $(username).
Masalah tersebut bisa diatasi dengan menghapus Active session user manager melalui menu Sessions. Tapi masa iya tiap kali muncul error itu kita harus clear inactive session manual, capek kan? Apalagi kalau user nya banyak, bisa tiap hari kerjaan nya cuma clear inactive session aja 😀


Remove Sessions pada User Manager Mikrotik
Nah, untuk mengatasi hal tersebut kita bisa memanfaatkan Script yang dijalankan secara terjadwal (otomatis). Kita akan manfaatkan tool Script & Scheduler pada Mikrotik.


Menambahkan Script Auto Remove Session User Manager Mikrotik
Silakan copy Script berikut ini dan paste pada Manu System –> Scripts
# Script Source : Mikrotik Forums
# Script Starts Here.
# Setting Timeout in Seconds
# Timeout in Seconds, when session update is older -> session closed
:local Timeout 60

#——————————————
:local LastSessionUpdate;
:local SessionTimeout;
:foreach i in=[/tool user-manager session find where active=yes] do={

# When was the last Update of the session-informations
:set LastSessionUpdate [/tool user-manager session get $i till-time]

# SessionTimeout is a value that tells me how many seconds ago the last update of this session was
:set SessionTimeout ([system clock get time] – [:pick $LastSessionUpdate ([:find $LastSessionUpdate ” “]+1) [:len $LastSessionUpdate]]-[/system clock get gmt-offset])

# if last update is more then Timeout seconds ago then close session and log it
:if ($SessionTimeout > $Timeout) do={
/tool user-manager session remove numbers=$i
:log warning (” Removed false active session Username is ” . [/tool user-manager session get $i user]);
}
}
Kemudian jalankan secara otomatis script tersebut menggunakan Scheduler.

Silakan set interval berapa lama script nya akan dieksekusi secara otomatis. Set interval sesuai dengan beban router Anda. Misal pada beban sekitar 150+ user pada router low end, dijadwalkan untuk setiap 5 menit. Karena script ini butuh waktu beberapa saat untuk melakukan perhitungan setiap user. Jadi tinggal sesuaikan saja dengan spek Router Mikrotik Anda.

Dengan melakukan kedua Tutorial Mikrotik tersebut permasalahan No More Sessions are Allowed for User pada Hotspot Mikrotik bisa diatasi. Saya sendiri sudah coba untuk yang User Manager dan 100% Work, tidak lagi muncul pesan error no more session saat user login.
HOTSPOT MIKROTIK LANJUT SCRIPTING USER MANAGER